Author Topic: Lumberjack's being lazy, but why?  (Read 655 times)

Thiosis Omain

  • Newbie
  • *
  • Posts: 5
    • View Profile
Lumberjack's being lazy, but why?
« on: January 27, 2017, 06:09:20 PM »
So I am stuck on a stand still with my lumberjack's, they want to work when no area is defined and the gates are empty, but when set a work location(with the zone planner) they sit idle as inactive in thier tool tip. My set up is like so.

4x structure pipes with a docking station and a Emerald OR gate on each.

Gates are set to when red pipe is on -> work in area, when no red pipe -> go to station

My chest has a Emerald OR gate as well with items in inventory -> provide items -> diamond axe.

When the lever is off and red pipe is off the robots are actively doing nothing because of the go to station command, working as intended, but when I flip it on to turn on red pipe and thus tell em to go to work thier little cute lights turn off, inactive tooltip pops up and its nap time for the lazy lumberjack.

What is it I'm doing wrong? I've tried giving them each thier own area or all working in the same one. Oh and my lever is on a separate structure pipe with its own gate for redstone on send red pipe etc...

Edit1; v. 7.1.19 MC 1.7.10

Edit2; Screenshots http://imgur.com/a/lAeDl
« Last Edit: January 27, 2017, 08:40:46 PM by Thiosis Omain »

MaterZone

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Lumberjack's being lazy, but why?
« Reply #1 on: January 28, 2017, 03:29:46 AM »
I have the same issue. Looks like, "Work in area" command doesn't work properly. The only way to make robot work in specified area is to remove the map. And when robot goes to grab an axe, place the map back into the gate. Unfortunately, robot will only chop 1 tree and then come back to the gate(

I'm sorry, but where should I submit this bug?

I have Minecraft 1.8.9, BC 7.2.8

Edit
Looks like the robot goes to sleep and wakes up constantly, the light is flashing rapidly
« Last Edit: January 28, 2017, 03:38:32 AM by MaterZone »

AlexIIL

  • Administrator
  • Jr. Member
  • *****
  • Posts: 77
    • View Profile
Re: Lumberjack's being lazy, but why?
« Reply #2 on: January 28, 2017, 03:45:10 AM »
You might need to set the "load and unload in area" to point to the robot station next to the gate?

Thiosis Omain

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Lumberjack's being lazy, but why?
« Reply #3 on: January 28, 2017, 04:50:42 AM »
I have the same issue. Looks like, "Work in area" command doesn't work properly. The only way to make robot work in specified area is to remove the map. And when robot goes to grab an axe, place the map back into the gate. Unfortunately, robot will only chop 1 tree and then come back to the gate(

I'm sorry, but where should I submit this bug?

I have Minecraft 1.8.9, BC 7.2.8

Edit
Looks like the robot goes to sleep and wakes up constantly, the light is flashing rapidly
 

The only reason my bots have an axe was because I placed them before I placed the gates so they just whent for the first thing on their to do list which is grab an axe where ever possible, then go cutting where ever ther is a tree, once I set the gates up they came back and haven't moved since(other then some twiching which gets my hopes up).

You might need to set the "load and unload in area" to point to the robot station next to the gate?

I don't follow, I've only ever used the unload/load with my pickers. Getting carriers to work right blows my brain up so I stick with the aforementioned pickers. But even if I did set a load location to my axe chest would they not just pick an axe and return to their main dock and back to sitting idle? I will try this maybe it will kick start thier programing.

Thiosis Omain

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Lumberjack's being lazy, but why?
« Reply #4 on: January 28, 2017, 06:45:56 PM »
Tried the unload and load in area and to no avail, they did however move to my charging station to charge up after sitting idle long enough to drain thier internal battery. Made my docking/chest/charging station on my zone planner a bit bigger just in case and still no movement.

LuigiHutch

  • Newbie
  • *
  • Posts: 21
    • View Profile
Re: Lumberjack's being lazy, but why?
« Reply #5 on: January 28, 2017, 09:07:58 PM »
Singleplayer or muliplayer?  can you post your logs in a gist/pastebin which may help diognose the problem

Thiosis Omain

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Lumberjack's being lazy, but why?
« Reply #6 on: January 28, 2017, 10:01:47 PM »
Single player creative, very first time with pastebin so I hope I did the right thing, I took my log's from the 27Th, very green to this so not 100% sure what I'm doing.

http://pastebin.com/8P86ybTg

Thiosis Omain

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Lumberjack's being lazy, but why?
« Reply #7 on: January 30, 2017, 03:16:16 AM »
Found my issue, it wasn't a buildcraft issue I don't think see I also run a few other mods and one of em put a reduced durability on all the vanilla tools and all the lumberjack's tools didn't break they just sat at 0 durability so all I had to do was knock the old axe off with a bc wrench and they whent to work but thanks for all the help I appreciate it.